Sell For US-Issued Cards
Incident Report for Jiggle
Update
We are pleased to inform you that the off-ramp feature is now available for US users through SWIFT bank transfer, offered by our exchange partner, Waltzer. Please note that there is a minimum off-ramp value of $1,000 USD when using this method.

We understand the importance of flexibility, and our exchange partner are actively exploring additional alternatives to provide more off-ramp options for our users moving forward. Thank you for your patience and continued support. If you have any questions, please feel free to reach out to our support team.
Posted Oct 07, 2024 - 16:05 UTC
Monitoring
We regret to inform you that due to unforeseen circumstances, the "Sell" feature is temporarily unavailable for users with US-issued cards. This issue sits with the Waltzer exchange, and their team is working diligently to resolve this issue as quickly as possible. We apologise for any inconvenience this may cause and appreciate your patience. We will provide updates as soon as we have more information.

Thank you for your understanding.

Best wishes, Jiggle support.
Posted Jul 13, 2024 - 04:00 UTC
This incident affects: Waltzer Exchange - Sell Crypto.