This issue has now been resolved. Please note that fee loading times may still be slightly delayed, but users will now be able to send BTC successfully.Thank you for your patience while we worked to address this issue.
Posted Jan 13, 2025 - 12:25 UTC
Monitoring
We have identified an issue with one of our providers that is impacting the ability of some users to send Bitcoin. Our team has pinpointed the source of the problem and is actively working on implementing a fix. Thank you for your patience as we resolve this matter.
Posted Jan 13, 2025 - 09:43 UTC
This incident affected: Supported Currencies (Bitcoin (BTC)).