Jiggle web wallet downtime

Incident Report for Jiggle

Resolved

This incident has now been resolved.
Posted Oct 17, 2024 - 11:40 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 17, 2024 - 11:23 UTC

Identified

The Jiggle web wallet is currently experiencing some downtime. Our team is actively working to resolve the issue as quickly as possible. We appreciate your patience and will keep you updated as soon as the service is restored. If you have any further questions, feel free to reach out.
Posted Oct 17, 2024 - 11:22 UTC
This incident affected: Jiggle - Web Wallet.